ホーム > 日記 > postfixでQdmail1.26bを利用する場合の注意

postfixでQdmail1.26bを利用する場合の注意

デコメ送信ライブラリとして利用されるQdmailをpostfixで利用する場合、sendmail完全互換ではないため以下のようなエラーが発生する。

sendmail: invalid option -- d
sendmail: invalid option -- 0
sendmail: invalid option -- .
sendmail: invalid option -- 1
sendmail: invalid option -- d
sendmail: fatal: usage: sendmail [options]

qmail.phpの1186行目から以下のようにコメントアウトする。

PHP
    //If(false !== @system($sendmail_path.' -d0.1 < /dev/null > /dev/null',$ret)){
    //  if(is_array($ret)){
    //    $ret = reset($ret);
    //  }
    //  $code = (int) substr($ret,0,3);
    //  if( 100 === $code || 111 === $code){
    //    $this->is_qmail = true;
    //  }
    //}

via:サポート ? Qdmail ? PHP::Mail Library , Quick and Detailed for Multibyte

カテゴリー: 日記 タグ: