ホーム > 日記 > symfony1.0のサポートはPHP5.0ですが

symfony1.0のサポートはPHP5.0ですが

symfony1.0のサポートはPHP5.0ですが、開発はPHP5.2とPEARが推奨されます。
プラグインの利用でPHP5.2とPEARが必須です。

$ ./symfony plugin-install http://plugins.symfony-project.com/sfJqueryPlugin
PHP Fatal error:  Call to undefined function date_default_timezone_set() in /path/to/lib/vendor/symfony/data/tasks/sfPakePlugins.php on line 189

開発だけは5.2、PEAR必須なだけで、動作には必要ないかもしれません。
各種プラグインは1.0対応を謳ってるのにインストールしようとしたらPHP>5.10とでてくるものがあったり怪しいので注意が必要です。
PHP5.2使いたいところなんですが、CentOS5.2はPHP5.1.6なんですよね。。。

カテゴリー: 日記 タグ:
  1. コメントはまだありません。
  1. トラックバックはまだありません。